物好き者

物好き者が行ったことを載せています。

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

PageTop

smtp認証機能が無い機器からのメール送信に挑戦13

WHR-HP-G54とWLI-TX4-G54HPへのSDカード取り付けがうまくいっていないため、perlやOptwareのインストールが出来ません。

smtp認証機能が無い機器からのメール送信に挑戦9 で、http://www.cip.ifi.lmu.de/~colberg/openwrt/bin/kamikaze/7.09/atheros-2.6/ のパッケージのうち、libdb1-compat_2.1.3-1_mips.ipk・libgdbm_1.8.3-1_mips.ipk・perlbase-gdbm-file_5.8.8-3_mips.ipk をインストールしましたが、smtpproxが動作しませんでした。

http://www.cip.ifi.lmu.de/~colberg/openwrt/bin/kamikaze/7.09/atheros-2.6/ にはperl関連のパッケージがいろいろとあるので、すべてをLaFoneraに接続したSDカードにインストールしてみました。

つづきを表示

PageTop

smtp認証機能が無い機器からのメール送信に挑戦12

smtp認証機能が無い機器からのメール送信に挑戦11 で、WLI-TX4-G54HPにOptWareをインストールするためには、UNIX系のファイルシステムが必要とわかりました。

Lafoneraのフラッシュメモリをnfsでエクスポートして、WLI-TX4-G54HPでnfsでマウントしてみることにしました。

YoMolo.Com のnfs-serverパッケージをインストールしてみました。

root@LaFonera2:/tmp# wget http://www.yomolo.com/wifi/archivos/fonera/mirror/nfs-server_2.2beta47-1_mips.ipk
Connecting to www.yomolo.com [208.109.14.75:80]
root@LaFonera2:/tmp# ipkg install nfs-server_2.2beta47-1_mips.ipk
ERROR: File not found: //usr/local/lib/ipkg/lists/whiterussian
You probably want to run `ipkg update'
ERROR: File not found: //usr/local/lib/ipkg/lists/non-free
You probably want to run `ipkg update'
ERROR: File not found: //usr/local/lib/ipkg/lists/backports
You probably want to run `ipkg update'
/bin/ipkg: /bin/ipkg: 1184: sort: not found
Unpacking nfs-server...Done.
Configuring nfs-server...Done.

つづきを表示

PageTop

smtp認証機能が無い機器からのメール送信に挑戦11

smtp認証機能が無い機器からのメール送信に挑戦10 で、エンディアンの違いからLaFoneraにはOptwareのインストールが出来ませんでした。

このため、WLI-TX4-G54HPにOptWareをインストールすることにしました。
フラッシュメモリの容量が少ないので、Windows共有をmountして、そこにインストールすることにしました。

つづきを表示

PageTop

smtp認証機能が無い機器からのメール送信に挑戦10

DD-WRTのサイトでperlについて検索したところ、Optwareにperlがあるそうです。
Optware - DD-WRT Wiki
Optware-ByHand - DD-WRT Wiki
Quick list of Optware packages - DD-WRT Wiki

このため、Optwareのインストールをしてみます。
フラッシュメモリの容量から、LaFoneraにインストールすることにしました。

つづきを表示

PageTop

smtp認証機能が無い機器からのメール送信に挑戦9

smtp認証機能が無い機器からのメール送信に挑戦8 で、LaFoneraにインストールしたperl_5.8.8-3_mips.ipkでsmtpproxが動作しませんでした。

http://ipkg.nslu2-linux.org/feeds/optware/ddwrt/cross/stable/Packages を見るとパッケージの依存が書かれていました。
Depends: libdb, gdbm
バージョンが違いますが、この二つをインストールしてみました。

つづきを表示

PageTop
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。