物好き者

物好き者が行ったことを載せています。

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

PageTop

WLAE-AG300へDD-WRTをインストールしました

WLAE-AG300を入手したので、DD-WRTをインストールしてみました。

シリアル接続を使用できるように分解をしようとしたのですが、かなり面倒でした。
裏面のねじを5本はずしたのですが、簡単にカバーが外れません。
いろいろ試すと、ねじを外した裏面側でなく、表面側が外せました。
外すときは、表面と枠の間の隙間を広げてマイナスドライバーなどでこじることでノッチが外れます。これを一周行うことで外せました。
wlae-ag300-1 wlae-ag300-2


シリアル用のPinはU36というもので、U36が読める状態で上から、3.3V・0V・3.3V・0Vでした。
Vcc・GND・TX・RXとして接続したところ、メッセージが出力されましたが、入力はできませんでした。
接続を変更しても入力ができないままなので、なにか調整が必要なのかもしれません。
wlae-ag300-3


純正ファームの更新バージョンがないため、Web管理画面のファームウェア更新から、DD-WRTを書き込みました。
http://www.dd-wrt.com/dd-wrtv2/downloads/others/eko/BrainSlayer-V24-preSP2/2011/06-14-11-r17201/buffalo_wlae_ag300n からダウンロードした buffalo-to-dd-wrt_webflash-MULTI.bin を書き込みました。

転送が終わると、Statusが赤点滅し、Ping応答がなくなりました。
30秒ぐらいでStatusが赤点灯、Wireless消灯となりました。
Web管理場面に表示されていた180秒を過ぎても、Statusが赤点灯のままです。

Powerボタンを長押ししても電源が切れないため、コンセントを抜いて電源を入れなおしても変わりません。

シリアルコンソールをつないでから電源を入れなおしてみると、dd-wrtが動いていました。
inSSIDer2.0で見ると、dd-wrtがありました。
有線NICのIPを192.168.1.10に変更し、192.168.1.1にアクセスするとWeb管理画面が表示されました。

Web管理画面で初期化、ファーム:wla-ag300-firmware-MULTI.bin を書き込みましたが、Statusランプは赤点灯のままで、300sからカウントダウンして30秒程度で再起動しました。

WZR-HP-G300NHなどの更新はもっと時間がかかったので、書き込みが完了しているとは思いませんでした。
また、StatusランプがU-Boot中でもdd-wrt起動後でも、Status:赤点灯:Wireless:消灯のため、状態がわかりにくいです。


設定を見てみると、br0は、eth0,eth1,ath0で構成されています。
VPNはPPTPのServerとClientはありますが、OpenVPNがありません。


Wirelessを見ると、Wireless Physical Interface ath0 [2.4/5 GHz] となっており、2.4GHzと5GHzが使えることが判ります。

Wireless Network Modeは、disabled・mixed・b-only・g-only・bg-mixed・a-only・ng-mixed・・n-only(2.4GHz)・na-mixed・N-only(5Ghz)があります。

mixedだと、2.4GHzと5GHzのチャンネルが選択できますが、2.4GHzと5GHzのどちらかしか選択できません。
mixed・a-only・na-mixed・N-only(5Ghz)では5GHz、それ以外とmixedでは2.4GHzが利用できるようです。

Virtual Interfacesを追加しても、Wireless Network Modeを別に設定することはできません。
このため、2.4GHzと5GHzを同時に使うことはできないようです。

2.4GHzと5GHzが同時に使いたいのですが、dd-wrtだとできないのでしょうか。WZR-HP-AG300でも同じようにどちらかしか使用できないのでしょうか。

openwrtをコンパイルしてWZR-AMPG144NHにインストールすると、NICが別なので設定も個別に表示されるため、同時に利用できそうですが、いまだに動かすことができていません。
openwrtでもdd-wrtでも、MarvellOrion系をフルサポートしてほしいところです。


dd-wrtのStatus画面で確認すると、次のようになっています。

Router Model:Buffalo WLAE-AG300N
CPU Model:Atheros AR7240 rev 1.2 (0x00c2)
CPU Clock:400 MHz
Memory:Total Available 29.2 MB / 32.0 MB

WZR-HP-G300NHと同じAtherosなので、ClientBridgeでの運用は難しいようです。
Gargoyleファームも提供されていないため、WDSの検証を行っていきます。

スポンサーサイト

PageTop

コメント


管理者にだけ表示を許可する
 

承認待ちコメント

このコメントは管理者の承認待ちです

| | 2014年07月25日(Fri)05:34 [EDIT]


上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。