物好き者

物好き者が行ったことを載せています。

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

PageTop

WHR-HP-G54へSDカードスロット取り付け2

WHR-HP-G54へSDカードスロット取り付け1 でSDカードがうまく動きませんでした。

検索したところ、次のページが見つかりました。
SD/MMC mod - DD-WRT Wiki には、次のように書かれています。
To answer this we need to use the multi-meter again. Send the command described above to make the LED that needs to be analyzed flash on-off-on. Ground one probe and measure the voltage on each side of the LED. We need to use the side of the LED that that changes between about 0.2 volt when it is on, and 3.3 volt when it is off. The wrong side will be at about 2 volts when the LED is on, and 3.3 volt when it is off.

In the Buffalo router one side of the LED is marked with a "+", we will need to use the other side of the LED.

OpenWrt / MMC/SD Card module not working after upgrade to RC5 には、次のように書かれています。
DO (gpio 4 - Cisco buton as told but i cant confirm) always 3.3v. (????) it should variate right ?????

DI (gpio2 - white led) variations between 0.2 and 3.3v. led fashes
CLK (gpio 3 - amber led) variations between 0.2 and a.8v but led always on
CS (gpio 7 - dmz led) variations between 0.2 and 3.3v. led fashes
VDD off course 3.3v stable

WHR-HP-G54へSDカードスロット取り付け1 では、DIで使うGPIO5が3.3v/0.3vですが、それ以外は電圧が違います。
LED部分のGPIOで電圧が違うので、チップ抵抗を飛ばしてしまったため電圧が異なっていると思われます。

動作しないのは、電圧が違うためSDカードに正常にアクセスできないことが原因と思います。

RC6.2で試していますが、念のためRC3でテストしてみます。
また、DD-WRT Forum :: View topic - Buffalo WHR-G54S JTAG Pinout!! では、v24Beta2007/08/15で動作している人がいるので、このバージョンでもテストしてみます。
さらに、DD-WRT Forum :: View topic - Buffalo WHR-HP-G54 SD/MMC Mod NOW WORKING!! WHR-G54S Too!!! では、dd-wrt.SP3.MMC-BUFF.generic.bin というファームウェアがあるということなので、こちらもテストしてみます。

RC6.2からWeb管理画面でRC3にファームウェア変更をしたところ、起動してきません。
シリアルコンソールで確認すると、次のようになっておりファームウェアが起動してきません。
Device eth0: hwaddr 00-0D-0B-CB-3D-0A, ipaddr 10.3.2.6, mask 255.255.255.0
gateway not set, nameserver not set
Boot program checksum is invalid
Reading :: Failed.: Timeout occured

このため、tftpでRC3をインストールしました。
起動後にSDカードの動作確認しましたが、現象は変わりませんでした。
v24Beta2007/08/15にWeb管理画面からファームウェア更新をしてSDカードの動作確認しましたが、現象は変わりませんでした。
さらに、dd-wrt.SP3.MMC-BUFF.generic.bin ファームウェア更新をしましたが、現象は変わりませんでした。

OpenWRT 7.09 をインストールしたところ、mmcモジュールが無いため動作しませんでした。
OpenWrtDocs/Customizing/Hardware/MMC - OpenWrt に、http://www.partners.biz/dd-wrt/mmc-buffalo.tar があったので、これを読み込ませてみましたが、動作しませんでした。

はんだづけがうまくいかずチップ抵抗をなくしたりしたのが原因のようなので、WLI-TX4-G54HPに対してはんだづけしないで行って見たいと思います。

スポンサーサイト

PageTop

コメント


管理者にだけ表示を許可する
 

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。