物好き者

物好き者が行ったことを載せています。

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

PageTop

smtp認証機能が無い機器からのメール送信に挑戦11

smtp認証機能が無い機器からのメール送信に挑戦10 で、エンディアンの違いからLaFoneraにはOptwareのインストールが出来ませんでした。

このため、WLI-TX4-G54HPにOptWareをインストールすることにしました。
フラッシュメモリの容量が少ないので、Windows共有をmountして、そこにインストールすることにしました。

LaFoneraの時と同じ手順を経て、sh /tmp/optware-install.shを実行しました。

root@WLI-TX4-G54HP:/jffs/smtpprox-1.2# sh /tmp/optware-install.sh
Checking system config ...
Using 10.3.2.8 as default gateway.
Using the following nameserver(s):
nameserver 10.3.2.2
Installing package uclibc-opt_0.9.28-12_mipsel.ipk ...
Connecting to ipkg.nslu2-linux.org [140.211.167.165:80]
Updating /opt/etc/ld.so.cache
/opt/sbin/ldconfig: can't link /opt/lib/libutil.so.0 to libutil-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libc.so.0 to libuClibc-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libthread_db.so.1 to libthread_db-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libstdc++.so.6 to libstdc++.so.6.0.8: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/librt.so.0 to librt-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libresolv.so.0 to libresolv-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libpthread.so.0 to libpthread-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libnsl.so.0 to libnsl-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libmudflapth.so.0 to libmudflapth.so.0.0.0: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libmudflap.so.0 to libmudflap.so.0.0.0: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libm.so.0 to libm-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libintl.so.0 to libintl-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libdl.so.0 to libdl-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libcrypt.so.0 to libcrypt-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/ld-uClibc.so.0 to ld-uClibc-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't create /opt/etc/ld.so.cache~ (No such file or directory)
Installing package ipkg-opt_0.99.163-9_mipsel.ipk ...
Connecting to ipkg.nslu2-linux.org [140.211.167.165:80]
/opt/sbin/ldconfig: can't link /opt/lib/libutil.so.0 to libutil-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libc.so.0 to libuClibc-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libthread_db.so.1 to libthread_db-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libstdc++.so.6 to libstdc++.so.6.0.8: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/librt.so.0 to librt-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libresolv.so.0 to libresolv-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libpthread.so.0 to libpthread-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libnsl.so.0 to libnsl-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libmudflapth.so.0 to libmudflapth.so.0.0.0: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libmudflap.so.0 to libmudflap.so.0.0.0: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libm.so.0 to libm-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libipkg.so.0 to libipkg.so.0.0.0: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libintl.so.0 to libintl-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libdl.so.0 to libdl-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libcrypt.so.0 to libcrypt-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/ld-uClibc.so.0 to ld-uClibc-0.9.28.so: Operation not supported
/tmp/optware-install.sh: /tmp/optware-install.sh: 92: /opt/bin/ipkg: not found
/tmp/optware-install.sh: /tmp/optware-install.sh: 93: /opt/bin/ipkg: not found
/tmp/optware-install.sh: /tmp/optware-install.sh: 94: /opt/bin/ipkg: not found

しかし、/opt/sbin/ldconfig: can't link というエラーが発生し、インストールが出来ません。
Optware-ByHand - DD-WRT Wiki の方法で、手動でパッケージのインストールをしてみましたが、現象は変わりません。
root@WLI-TX4-G54HP:/jffs# ipkg install ipkg-opt_0.99.163-9_mipsel.ipk
ERROR: File not found: /jffs/usr/lib/ipkg/lists/whiterussian
You probably want to run `ipkg update'
ERROR: File not found: /jffs/usr/lib/ipkg/lists/non-free
You probably want to run `ipkg update'
ERROR: File not found: /jffs/usr/lib/ipkg/lists/backports
You probably want to run `ipkg update'
Unpacking ipkg-opt...Done.
Configuring ipkg-opt...Done.
root@WLI-TX4-G54HP:/jffs# mount -o bind /jffs/opt /opt
root@WLI-TX4-G54HP:/jffs# ipkg install uclibc-opt_0.9.28-12_mipsel.ipk
ERROR: File not found: /jffs/usr/lib/ipkg/lists/whiterussian
You probably want to run `ipkg update'
ERROR: File not found: /jffs/usr/lib/ipkg/lists/non-free
You probably want to run `ipkg update'
ERROR: File not found: /jffs/usr/lib/ipkg/lists/backports
You probably want to run `ipkg update'
Unpacking uclibc-opt...Done.
Configuring uclibc-opt...Updating /opt/etc/ld.so.cache
/opt/sbin/ldconfig: can't link /opt/lib/libutil.so.0 to libutil-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libc.so.0 to libuClibc-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libthread_db.so.1 to libthread_db-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libstdc++.so.6 to libstdc++.so.6.0.8: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/librt.so.0 to librt-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libresolv.so.0 to libresolv-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libpthread.so.0 to libpthread-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libnsl.so.0 to libnsl-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libmudflapth.so.0 to libmudflapth.so.0.0.0: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libmudflap.so.0 to libmudflap.so.0.0.0: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libm.so.0 to libm-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libipkg.so.0 to libipkg.so.0.0.0: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libintl.so.0 to libintl-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libdl.so.0 to libdl-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libcrypt.so.0 to libcrypt-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/ld-uClibc.so.0 to ld-uClibc-0.9.28.so: Operation not supported
Done.

環境変数 IPKG_CONF_DIR に指定したディレクトリの ipkg.conf ファイルを使うということで、設定後に ipkg update を実行してみました。
しかし、同じエラーが出てしまいます。
root@WLI-TX4-G54HP:/jffs# export IPKG_CONF_DIR=/opt/etc
root@WLI-TX4-G54HP:/jffs# ipkg update
Downloading http://www.wlan-sat.com/boleo/optware/dd-wrt/Packages ...
Connecting to www.wlan-sat.com [212.18.63.81:80]
wget: server returned error: HTTP/1.1 404 Not Found
ipkg_download: ERROR: Failed to retrieve http://www.wlan-sat.com/boleo/optware/dd-wrt/Packages, returning
ipkg_update: Error downloading http://www.wlan-sat.com/boleo/optware/dd-wrt/Packages to /jffs/usr/lib/ipkg/lists/unslung

root@WLI-TX4-G54HP:/jffs/usr/lib/ipkg/lists# vi /opt/etc/ipkg.conf
src optware http://ipkg.nslu2-linux.org/feeds/optware/ddwrt/cross/stable
dest root /jffs
root@WLI-TX4-G54HP:/jffs/usr/lib/ipkg/lists# ipkg update
Downloading http://ipkg.nslu2-linux.org/feeds/optware/ddwrt/cross/stable/Packages ...
Connecting to ipkg.nslu2-linux.org [140.211.167.165:80]
wget: /jffs/tmp/ipkg/Packages: No such file or directory
ipkg_download: ERROR: Failed to retrieve http://ipkg.nslu2-linux.org/feeds/optware/ddwrt/cross/stable/Packages, returning
ipkg_update: Error downloading http://ipkg.nslu2-linux.org/feeds/optware/ddwrt/cross/stable/Packages to /jffs/usr/lib/ipkg/lists/optware
root@WLI-TX4-G54HP:/jffs/usr/lib/ipkg/lists# mkdir -p /jffs/tmp/ipkg
root@WLI-TX4-G54HP:/jffs/usr/lib/ipkg/lists# ipkg update
Downloading http://ipkg.nslu2-linux.org/feeds/optware/ddwrt/cross/stable/Packages ...
Connecting to ipkg.nslu2-linux.org [140.211.167.165:80]
Packages 100% |*****************************| 372 KB 00:00:00 ETA
Done.
Updated list of available packages in /jffs/usr/lib/ipkg/lists/optware
root@WLI-TX4-G54HP:/jffs/usr/lib/ipkg/lists# /bin/ipkg install ipkg-opt

Downloading http://ipkg.nslu2-linux.org/feeds/optware/ddwrt/cross/stable/uclibc-opt_0.9.28-12_mipsel.ipk ...
Connecting to ipkg.nslu2-linux.org [140.211.167.165:80]
uclibc-opt_0.9.28-12 100% |*****************************| 833 KB 00:00:00 ETA
Done.
Unpacking uclibc-opt...Done.
Configuring uclibc-opt...Updating /opt/etc/ld.so.cache
/opt/sbin/ldconfig: can't link /opt/lib/libutil.so.0 to libutil-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libc.so.0 to libuClibc-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libthread_db.so.1 to libthread_db-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libstdc++.so.6 to libstdc++.so.6.0.8: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/librt.so.0 to librt-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libresolv.so.0 to libresolv-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libpthread.so.0 to libpthread-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libnsl.so.0 to libnsl-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libmudflapth.so.0 to libmudflapth.so.0.0.0: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libmudflap.so.0 to libmudflap.so.0.0.0: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libm.so.0 to libm-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libintl.so.0 to libintl-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libdl.so.0 to libdl-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/libcrypt.so.0 to libcrypt-0.9.28.so: Operation not supported
/opt/sbin/ldconfig: can't link /opt/lib/ld-uClibc.so.0 to ld-uClibc-0.9.28.so: Operation not supported
Done.

Downloading http://ipkg.nslu2-linux.org/feeds/optware/ddwrt/cross/stable/ipkg-opt_0.99.163-9_mipsel.ipk ...
Connecting to ipkg.nslu2-linux.org [140.211.167.165:80]
ipkg-opt_0.99.163-9_ 100% |*****************************| 75782 00:00:00 ETA
Done.
ipkg_install_file: ERROR: ipkg-opt depends on the following uninstalled programs:
uclibc-opt
ipkg_install_file: You may want to use `ipkg install' to install these.
ipkg_get_install: ERROR: Failed to install /jffs/tmp/ipkg/ipkg-opt_0.99.163-9_mipsel.ipk
ipkg_get_install: I'll leave it there for you to try a manual installation

Manpage of ldconfig にあるオプションでいろいろ試しましたが、現象は変わりません。

検索したところ、下記の情報が見つかりました。
DD-WRT Forum :: View topic - Problem installing Optware
これによると、Windowsファイルシステム上へはインストールできないということです。
WLI-TX4-G54HPのフラッシュメモリ容量が足りないので、Windowsファイル共有をmountしていましたので、このせいのようです。

LaFoneraの/jffsをNFSでmountするか、SDカードを使えるようにしてからOptWareのインストールを行うことにしました。

スポンサーサイト

PageTop

コメント


管理者にだけ表示を許可する
 

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。