物好き者

物好き者が行ったことを載せています。

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

PageTop

WZR-HP-G300NHには複数ハードウェアバージョンがあるそうです

Internet接続用ルーターをWZR-HP-G301NHに切り替えたので、それまで使っていたWZR-HP-G300NHにOpenWRTを書き込みました。
しかしネットワークが何も使えない状態となりました。
10.03.1-rc5を最初に書き込んだので、rc-4、rc-3、10.03、trunkなどを書き込んでみたのですが、やはりネットワークが使えないままです。

以前別のWZR-HP-G300NHでは問題なく使えたので、OpenWRTに問題は無いはずです。
また、dd-wrtでは問題なくネットワークが使えます。

シリアルコンソールで見ていたところ、次のエラーがありました。
Atheros AR71xx SPI Controller driver version 0.2.4
Realtek RTL8366S ethernet switch driver version 0.2.2
rtl8366s rtl8366s: using GPIO pins 19 (SDA) and 20 (SCK)
rtl8366s rtl8366s: unknown chip id (0000)
rtl8366s rtl8366s: chip detection failed, err=-19
eth0: Atheros AG71xx at 0xb9000000, irq 4
eth0: unable to find MII bus on device 'rtl8366s'
eth0: Atheros AG71xx at 0xba000000, irq 5
eth0: unable to find MII bus on device 'rtl8366s'
Atheros AR71xx hardware watchdog driver version 0.1.0

つづきを表示

スポンサーサイト

PageTop

WZR-HP-G300NHの日本版でtftpによる書き込みが出来るようにしました

WZR-HP-G300NHへOpenWRTをインストールしました では、tftpによるOpenWRTの書き込みが出来ないため、ファームの入れ替えを行う場合は、dd-wrtを書き込んでからmtdにて書き込む必要がありました

OpenWRTだけでなく、Gargolyeファームのtftp版もtftpによる書き込みが出来ないため、ファームの問題ではなくWZR-HP-G300NHの問題と考えます。

Internetで調べたところ、Buffalo WZR-HP-G300NH - OpenWrt Wiki のProblem with Japanese version, locked u-boot に情報がありました。

US版とJP版ではu=Bootの設定に違いがあり、US版で設定されている変数を登録することで、JP版でもtftpで書き込むことが出来るそうです。

記載されていた下記のコマンドを実行することで、起動時にPCからtftpでファームを転送後、自動で書き込まれるようになりました。
setenv accept_open_rt_fmt 1
saveenv
reset

これでファームの入れ替えが簡単になりました。

PageTop

300MリンクがWZR-HP-G301NHでは継続しています

dd-wrtで300Mリンクが継続しません で、WZR-HP-G300NHの300Mリンクが継続しませんでした。

dd-wrtを06-14-11-r17201 に更新したのですが、現象は変わりませんでした。

WDSでDLNAを利用するようにしました で、WZR-HP-G301NHに 06-14-11-r17201 をインストールして、AP+WDSで稼動させています。
300M設定を行ってあるのですが、この環境では300Mリンクが継続しており、電波状況を見ると40MHzを利用したままです。


40MHzが継続しないWZR-HP-G300NHのAPには、WLI-TX4-G54HPをClientBridge設定で接続しています。
11gのため20MHz利用となりますが、これが接続されている影響があるのかと思い、接続先をWZR-HP-G301NHに切り替えたのですが、40MHzが継続します。

またWDS Stationに設定しているWZR-HP-G300NHとは、300Mリンクを継続しています。

40MHzが継続しないのは、40MHz設定をしているWZR-HP-G300NHに問題がある、WZR-HP-G300NHをAP設定で利用している、などが影響していることも考えられますので、いろいろと組み合わせを変えて検証したいと思います。

PageTop

WDSでDLNAを利用するようにしました

37Z1SでRD-X10やRD-X6の録画番組を見るのは、次のような構成でDLNAを利用していました。

Internet接続ルーター---有線---MZK-W300NH2---有線---RD-X10、RD-x6
                          |
                    WZR-HP-G300NH(Gargoyle:Brdige)---有線---37Z1S

Internet接続ルーター---有線---MZK-W300NH2---有線---RD-X10、RD-x6
     |
      +---無線------------WZR-HP-G300NH(Gargoyle:Brdige)---有線---37Z1S

どちらの場合も、Gargoyleで稼動しているWZR-HP-G300NHの無線linkは継続するのですが、通信が行えない状態が頻発します。しばらくたつと通信ができるようになることもありますが、電源を入れなおさないと通信が回復しないときもあります。
WZR-HP-G300NHの置き場所を変えたり、Gargoyleの設定を変えたりしたのですが、現象はなくなりませんでした。

つづきを表示

PageTop

OpenVPNのフラグメント対策3

OpenVPNのフラグメント対策2 で、クライアント側の設定ファイルのtun-mtuが反映されないため、ネットワークインターフェースの構成でMTUを設定していました。

ddd-wrt 05-08-11-r16994 以降でOpenVPNを動かすことができました ので、Internet接続用WZR-HP-G300NHを 06-14-11-r17201 に更新しました。

OpenVPNのログをチェックしていたところ、次のエラーが繰り返し記録されており、OpenVPN経由での通信に遅れが発生していました。
WARNING: 'link-mtu' is used inconsistently local='link-mtu 1416' remote='link-mtu 1558'
WARNING: 'tun-mtu' is used inconsistently local='tun-mtu 1358' remote='tun-mtu 1500'


クライアント設定ファイルのtun-mtuが反映されないためtun-mtuを設定していませんでしたが、サーバー側と同じtun-mtu 1358を設定したところ、エラーが記録されなくなり通信のもたつきもなくなりました。

クライアント側のバージョンや設定を変更していなかったので、dd-wrt上のOpenVPNの処理が変更され、クライアント側のtun-mtuが反映されるようになったと思われます。

PageTop

WDS設定を行ってみました

WDSは扱いが難しいようです でWZR-HP-G300NHとLafonera+で検証したのですが、うまく動かすことができませんでした。

今回は、WZR-HP-G301NHとWLAE-AG300に06-14-11-r17201をインストールして、設定を行いました。

WZR-HP-G301NHをWDS AP、WLAE-AG300をWDS Stationとし、SSID、Securityを合わせ、WDSタブでLAN:対向機器MACアドレスを設定したところ、問題なく接続して通信が行えました。


Internet接続用ルーターでWDSを設定することを考え、WDS APでiptablesを確認すると、SPIはEnableなのに設定がすかすかでした。
WANがDHCPだったので、StaticにしてIPを設定したところ、iptablesにいろいろと設定されましたが、WDSでの通信が行えなくなりました。

WANをDHCPやDisableにしてiptablesの設定がすかすかなのを確認したのですが、再起動してもWDS通信が行えないままです。
初期化してから設定しなおすと、WDS通信が行えるようになりました。

つづきを表示

PageTop

dd-wrtで300Mリンクが継続しません

dd-wrtで300Mリンクさせる設定2 で、Channel1以外を選択することで、40MHzが使えるようになりました。

数日後にinSSIDer2.0で確認したところ、20MHzになっていました。
再起動やChannel変更を行うと40MHzとなるのですが、少したつと20MHzになります。

06-14-11-r17201 でDDNS更新が行われません で06-14-11-r17201にアップデートしましたが、やはり少したつと20MHzになってしまいます。

40MHzを安定して使うためには、設定を見直すなど調整か、dd-wrt側の調整が必要なようです。

PageTop

WLAE-AG300へDD-WRTをインストールしました

WLAE-AG300を入手したので、DD-WRTをインストールしてみました。

シリアル接続を使用できるように分解をしようとしたのですが、かなり面倒でした。
裏面のねじを5本はずしたのですが、簡単にカバーが外れません。
いろいろ試すと、ねじを外した裏面側でなく、表面側が外せました。
外すときは、表面と枠の間の隙間を広げてマイナスドライバーなどでこじることでノッチが外れます。これを一周行うことで外せました。
wlae-ag300-1 wlae-ag300-2


シリアル用のPinはU36というもので、U36が読める状態で上から、3.3V・0V・3.3V・0Vでした。
Vcc・GND・TX・RXとして接続したところ、メッセージが出力されましたが、入力はできませんでした。
接続を変更しても入力ができないままなので、なにか調整が必要なのかもしれません。
wlae-ag300-3


純正ファームの更新バージョンがないため、Web管理画面のファームウェア更新から、DD-WRTを書き込みました。
http://www.dd-wrt.com/dd-wrtv2/downloads/others/eko/BrainSlayer-V24-preSP2/2011/06-14-11-r17201/buffalo_wlae_ag300n からダウンロードした buffalo-to-dd-wrt_webflash-MULTI.bin を書き込みました。

転送が終わると、Statusが赤点滅し、Ping応答がなくなりました。
30秒ぐらいでStatusが赤点灯、Wireless消灯となりました。
Web管理場面に表示されていた180秒を過ぎても、Statusが赤点灯のままです。

Powerボタンを長押ししても電源が切れないため、コンセントを抜いて電源を入れなおしても変わりません。

シリアルコンソールをつないでから電源を入れなおしてみると、dd-wrtが動いていました。
inSSIDer2.0で見ると、dd-wrtがありました。
有線NICのIPを192.168.1.10に変更し、192.168.1.1にアクセスするとWeb管理画面が表示されました。

つづきを表示

PageTop

06-14-11-r17201 でDDNS更新が行われません

dd-wrt 05-08-11-r16994 以降でOpenVPNを動かすことができました でOpenVPNがつかることが判ったので、Internet接続用ルーターのWZR-HP-G300NHを、06-14-11-r17201 にアップデートしました。

OpenVPNやInternet接続は問題ないのですが、DDNSの更新が行われません。
Dyndnsを利用しているのですが、下記のログだけしか出力されません。
DDNS Status
Thu Jan 1 00:00:16 1970: INADYN: Started 'INADYN Advanced version 1.96-ADV' - dynamic DNS updater.
Thu Jan 1 00:00:16 1970: INADYN: IP read from cache file is 'アップデート前のPPPoEIP'. No update required.


svn14848ではDDNSが正常に動作しませんでした でsvn14848で更新できないことがありましたが、このときは認証周りでおかしかったようなので、今回は別の原因と考えられます。

とりあえずDyndnsのサイトで手動で更新しましたが、再起動のたびに行うのは面倒なのでバージョンを落とすことを検討しています。

PageTop

ddd-wrt 05-08-11-r16994 以降でOpenVPNを動かすことができました

V24_TNGの05/17/11でもOpenVPNが動きませんでした などで、05-08-11-r16994以降でOpenVPNが動かせませんでした。

別件で 06-14-11-r17201 をテストしていたときにログを見直しました。
Thu Jan 1 00:00:11 1970 WARNING: External program may not be called unless '--script-security 2' or higher is enabled. Use '--script-security 3 system' for backward compatibility with 2.1_rc8 and earlier. See --help text or man page for detailed info.
Thu Jan 1 00:00:11 1970 WARNING: Failed running command (--up/--down): external program fork failed
Thu Jan 1 00:00:11 1970 Exiting

前回は上記の2行目で動かないとして元のバージョンに戻しましたが、上記の1行目をチェックしたところ、設定の問題と考えました。

ログにあるように、下記コマンドでヘルプをチェックしました。(ヘルプは抜粋)
openvpn --help
--script-security level mode : mode='execve' (default) or 'system', level=
0 -- strictly no calling of external programs
1 -- (default) only call built-ins such as ifconfig
2 -- allow calling of built-ins and scripts
3 -- allow password to be passed to scripts via env

ログとあわせて考えると、このオプションで 2 または 3 が必要と考え、configに script-security 2 を追加したところ、OpenVPNが起動し利用することができました。

dd-wrt上のOpenVPNの問題でなく、設定の問題でした。

PageTop

Blu-rayのリージョンコード

Internetを見たいたら、Amazon.comで北米版のBlu-rayを購入している人がいました。

リージョンコードの問題で見れないのでは、と考えたのですが、DVDの8分割(国は6分割)とは違い、Blu-rayでは3分割だそうです。
Blu-ray Disc - Wikipedia
リージョンコード - Wikipedia

北米・カナダと日本は同じなので、北米・カナダのBlu-rayは日本でも見ることができるようです。
Box版などがかなり安く購入できるようなので、検討してみたいと思います。

PageTop
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。